You are not logged in.

Dear visitor, welcome to QtForum.org. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Sunday, July 21st 2013, 4:05pm

Can't add widget to form in Qt Designer

Ok, I've been using Qt for a while now, but I've never used the Designer. I tried when I started to learn Qt, but the behavior was so erratic, I just went to building forms by code. Anyway, I've got to edit a form someone else created using designer, and I'd rather just follow their process and edit the .ui file rather than convert everything to code, but I can't even add a widget to the form!

I've tried several things, but nothing seems to work. I've googled this and Qt's docs are no help (it just says a blue line appears on the form where rthe widget will be placed when you drag it over), and all the problem I see about people not being able to add widgets have to do with custom widgets.

This has to be a simple problem, but the answer isn't particularly forthcoming. Any reason as to why I can't drag / drop a standard widget into an existing form in Qt Designer? (Using Qt 4.8...)