You are not logged in.

Dear visitor, welcome to QtForum.org. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Thursday, October 20th 2011, 7:51pm

Problem with compiled QTCreator

Ok, so I want to write some plug-ins for QTCreator. So my first task is to compile QTCreator by myself. I installed Qt_SDK_Win_offline_v1_1_3 on C:\QtSDK\ (I'm using windows 7 professional btw)
Then I downloaded the source qt-creator-2.3.0-src.zip and extracted this on c:\qt-creator-2.3.0-src. So far so good. I found different manuals how to compile QTCreator and tried a lot of them but not often with succes, eventely this is how I did it;


- First, because i had a problem with the qwineventnotifier_p.h & qwineventnotifier_p.cpp I copied them from the src of QT 4.7.4 into C:\QtSDK\Desktop\Qt\4.7.4\mingw\include\QtCore\pri vate\

- I started Qt 4.7.4 for Desktop (MinGW) from my start menu.
- entered "cd c:\qt-creator-2.3.0-src-build" (first i created this folder of course)
- entered "qmake.exe C:\qt-creator-2.3.0-src\qtcreator.pro -spec win32-g++ -r CONFIG+=release"
- entered "mingw32-make release"

The compile process seemed to be ok (after more then an hour). When I then want to execute the qtcreator from the build map, I got the error that i couldn't find 5 dll's (mingwm10.dll,QTcore4.dll,...) , I copied them from C:\QtSDK\Desktop\Qt\4.7.4\mingw\bin into the folder.

Now I get the error "Failed to load core: C:\qt-creator-2.3.0-sro-build\lib\qtcreator\plugins\Nokia\Core.dll: Cannot load library C:/qt-
creator-2.3.0-sro-buiId/Iib/qtcreator/plugins/Nokia/Core.dll: The specified
module could not be found."

But the file is definitely on that location. I noticed the slash and back-slashes are wrong. Somebody an idea? I running out of ideas.

2

Thursday, October 20th 2011, 11:07pm

Problem solved, tried everything again and now its working :-)

Used tags

Compile, QtCreator