You are not logged in.

Dear visitor, welcome to QtForum.org. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Tuesday, November 2nd 2010, 2:53am

qtguid4.dll is missing from your computer

I downloaded and installed:
Qt libraries 4.7.0 for Windows (VS 2008, 226 MB)

When I create a project which uses Qt, it compiles and links fine with VS2008. When I run it, however, I get:

"The program cant start because qtguid4.dll is missing from your computer"

I searched for that file and it indeed does no exist. Anyone have any ideas why this would happen?

Thanks,

David

p.s. I had posted this is the "Installing" forum: qtguid4.dll is missing from your computer , but I guess technically it is installed already so maybe the question belongs here instead?

2

Tuesday, November 2nd 2010, 6:51am

Downloaded (Qt libraries 4.7.0 for Windows (VS 2008, 226 MB)) and it contains QtGuid4.dll



You need to add the directory (full path) where the QtGuid4.dll is to environment PATH variable then relog (or maybe not needed?).
Fighting fire with fire.
Three can keep a secret if two of them are dead.

3

Tuesday, November 2nd 2010, 12:08pm

Ah, that worked perfect! I expected the installer to do that! (I am a linux guy - I thought this was one of the whole points of Windows :) ).

Thanks for the help.

David

4

Wednesday, August 24th 2011, 8:47pm

I'm having the same problem, but i don't understood the "Messenger" solution. Can anyone explain me how can i reoslve the dll problem?

PS: the only different thing was that I downloaded the Qt libraries version 4.7.3 instead of the 4.7.0 version.

This post has been edited 1 times, last edit by "silverstain" (Aug 25th 2011, 2:12pm)


5

Sunday, August 28th 2011, 11:31pm

modify the environment variable PATH to include the location of the dll

http://pario.no/wp-content/uploads/2009/…nt-settings.png

6

Sunday, August 28th 2011, 11:37pm

thx amleto300, but when i did that, i found another error:

"The procedure entry point ?takeAt@QBoxLayout@@UAEPAVQLayoutItem@@H@Z could not be located in the dynamic link library QtGuid4.dll"

I post another topic about this, with the name "error opening .exe flie"
error opening the .exe file