You are not logged in.

Dear visitor, welcome to QtForum.org. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

kelvins

Beginner

  • "kelvins" is male
  • "kelvins" started this thread

Posts: 19

Location: New Zealand

  • Send private message

1

Wednesday, May 5th 2004, 10:22am

authorization, QTMac

Has anyone successfully got authentication working on a mac, using the authentication services, and calling a process as that priviliged user.

I am wanting to execute some code as root user. I can authenticate OK, but cannot get the communication pipe to the called program working. I have tried using both QProcess, and normal calls like execle.

I have tried to get the sample AuthSample from Apple working, but doesn't seem to want to.

Am looking for code example showing how this was achieved.

Cheers
QT 4.8.0
Linux